Skip Ribbon Commands
Skip to main content
Navigate Up
Sign In

UFIT Wiki

:

myUFL-Browser-Requirements

Effective 7/14/2017 after 5 PM upgrade

Web Browser Certifications

 

The following web browsers are certified to work with myUFL (versions higher than those listed below are likely to work without issue; lower versions will not):

 

Certified Browsers

Certified Version(s)

Internet Explorer

11

Edge

25

Chrome

43

Firefox

38 & 42

Safari

8 & 9

 
 Last modified at 7/11/2017 10:45 AM by Kiem Tran