Skip Ribbon Commands
Skip to main content
Navigate Up
Sign In

UFIT Wiki

:

What is the oldest version of Mac OS I should use

What is the oldest version of Mac OS I should use?

The oldest version of Macintosh that you should be using at UF is system 10.4.

 

Return to the Main FAQ page.

 
 Last modified at 7/12/2013 1:20 PM by Varvorines, Drake