Skip Ribbon Commands
Skip to main content
Navigate Up
Sign In

UFIT Wiki

:

What are the requirements to view a Mediasite presentation

What are the requirements to view a Mediasite presentation?

Windows
  • Microsoft Windows XP, Windows Server 2003, or Windows Vista.
  • Microsoft Internet Explorer 6.0 SP 1 or later, Firefox 2.0 or later, or Google Chrome 1.0 (Chrome is only supported on Mediasite version 5.0.3 and later).
  • Windows Media Player 9 or later.
  • For Firefox and Chrome playback, Silverlight 1.0 or later (viewers are prompted to install this when attempting to view a presentation).
  • Broadband Internet connection (256 Kbps or more)
Mac
  • Mac OS X 10.4.8 or later
  • Safari 2.0.4 or later or Firefox 2.0 or later.
  • Silverlight 1.0 or later (viewers are prompted to install this when attempting to view a presentation).
  • Broadband Internet connection (256 Kbps or more)
 
Note: Variable speed playback and multicast are not currently supported in Silverlight. Closed captioning and full screen video via Silverlight are available only in Mediasite 5.0 or later.
 
 
Return to the Main FAQ page.

 
 Last modified at 7/11/2013 3:36 PM by Varvorines, Drake