Skip Ribbon Commands
Skip to main content
Navigate Up
Sign In

UFIT Wiki

:

SupportedBrowsersForUFWebsites

Last modified at 3/2/2016 2:45 PM by Kiem Tran

Supported Browsers For UF Websites

*Updated May 2014*

 

Recommended/Supported Overall:

  • Firefox 7
  • Internet Explorer 8

 

Additional Recommendations:

  • Use Internet Explorer 8 when working with the People Soft Financials 9.1
  • Pop-up blockers should be set to allow pop-up messages from UF
  • Enable cookies
  • Enable JavaScript
  • Install or update Java to the current supported version
  • Verify that the computer's date, time, and time zone are correct
  • Click here for assistance checking your iPad Safari settings

 

How to Clear Cache and Cookies

Click here for instructions on how to clear your browser's cache and cookies.

 

Recommended Browers for e-Learning    (Back to Top)

  • Firefox versions 12-14 are recommended for all operating systems.
  • Internet Explorer versions 7, 8, and 9 are recommended for all Windows operating systems
  • There is limited mobile support for e-Learning

e-Learning Browser Chart

Supported Browsers for ONE.UF      (Back to Top)

  • All browsers are supported for all operating systems.

 

  Supported Browsers for CashNet      (Back to Top) 

 

 

 

 

 

 

 

 

 

 

 

 

  • Firefox 3.5 is supported for all operating systems.
  • Internet Explorer 7-10 are supported for the Windows operating systems.
  • Safari 5 is supported for all operating systems.
  • Chrome 9 is supported for Windows operating systems.

 

Supported Browsers for Cayuse424     (Back to Top)

  • Firefox is supported for all operating system.
  • Internet Explorer is supported for all operating system.
  • Please make sure your browser has Javascript Enabled
  • Please make sure your browser has Cookies Enabled
  • Please make sure your browser has Pop-ups Allowed for Cayuse

  

 

 

 Supported Browsers for Exchange    (Back to Top)
  • All browsers are supported for all operating systems.
  • Some browsers may use the Light version of Outlook Web Access, which has limited functionality.

Supported Browsers for File-Express   (Back to Top) 
  • All browser supported but may required plug-ins.


Supported Browsers for Gator Jobs    (Back to Top)
  • All operating systems are supported.
  • Firefox 3.5 and above is supported.
  • Internet Explorer 7 & 8 are supported.
  • Safari 4 and above is supported.
  • Chrome version 8 and above is supported.

Supported Browsers for Hyperion    (Back to Top)

  • Firefox 10 is supported for Windows 7 operating system.
  • Internet Explorer 8 and 9 are supported for Windows 7 operating system.
  • There is currently no official support for Windows 8.
Supported Applications for Hyperion
  • Microsoft Office 2003
  • Microsoft Office 2007
  • Microsoft Office 2010

 

Supported Browsers for SIS (Back to Top)
  • Firefox v. 4 and above are supported for all operating systems.
  • Internet Explorer 7, 8 & 9 are supported for all Windows operating systems.
  • Safari 5 is supported for all Windows & Mac operating systems.
  • There is limited mobile support for SIS.

 

 

 

 

 

 

 

 

 

 

 

 

 

Supported Browsers for CampusClarity     (Back to Top)

 

Note: Turn off popup blockers, enable cookies and javascript. Requires Adobe Flash and Reader.

 

 

Supported Browsers for myinvestiGator    (Back to Top)

  • Firefox 15 is supported for Windows 7 operating system.
  • Internet Explorer 8 and 9 are supported for Windows 7 operating system.
  • Chrome 21 is supported for Windows 7 operating system.
  • Safari 6 is supported for OSX 10.7 operating system.
  • There is currently no official support for Windows 8.

 

  

Supported Browsers for myIT   (Back to Top)

  •  Minimum supported browsers are:
    • Firefox 27 and above
    • Internet Explorer 9 and above
    • Safari 5.0 and above
    • Google Chrome 32 and above.

Supported Browsers for myTraining     (Back to Top)

 

Note: Pop-up blockers may block assessments.  You should disable pop-up blockers while using myTraining.


Firefox and Chrome are NOT supported.

 


 

 

Supported Browsers for myUFL    (Back to Top)
  • Please see myUFL Browser Requirements for additional browser instructions.
  • Firefox 17 supported for all Windows operating systems.
  • Internet Explorer 10 - 11 are supported for all Windows operating systems.
  • Use of Internet Explorer 9, 10 and 11 may require Compatibility View within the browser.

 Supported Browsers for myUF Market    (Back to Top)
  • Firefox (latest version) is supported for all operating systems.
  • Internet Explorer 8, 9, & 10 are supported for all Windows operating systems.
  • Safari v. 4 & above are supported for all Mac operating systems.
  • Chrome (latest version) is supported for all Windows operating systems.
 
 

Supported Browsers for myUF Payment Solutions     (Back to Top)

  • Firefox 23 and 24 are supported for all operating systems.
  • Internet Explorer 9 and 10 are supported for all Windows operating systems.
  • Safari v. 5 and 6 are supported for all Mac operating systems.
  • Chrome 30 and 31 are supported for all Windows operating systems.
 
Supported Browsers for OnBase   (Back to Top)

 

  • Minimum supported browsers are: Internet Explorer 9-11, Safari 6.1-8.0, and Firefox 31
NOTE! Chrome is NOT supported.
 
 
Supported Browsers for Webmail    (Back to Top)
  • Firefox (All Versions) are supported for all operating systems.
  • Internet Explorer 8 & 9 are supported for the Windows 7 operating system.
  • Internet Explorer 7 & 8 are supported for the Windows Vista operating system.
  • Internet Explorer 7 is supported for the Windows XP operating system.
  • Safari 3 is supported for Windows XP & all Mac operating systems.
  • Chrome is supported for Windows 7 & all Mac operating systems.
 

Supported Devices for the UF Mobile App     (Back to Top)
 
  • Android OS versions Gingerbread - Kit Kat supported.
  • iOS versions 5.0 and up are supported.

   

Return to the Main FAQ page.